Software Delivery Repository

Software Delivery Repository   |   Getting Started   |   FAQ  |  Repositories

Service Pack for ProLiant

The Linux Service Pack for ProLiant provides updated drivers and agent software for use on RedHat Linux and SUSE Linux Enterprise Server. For other distributions, please use the Management Component Pack (mcp) which contains agent software only (firmware is provided via HPSUM, and drivers are provided by the distribution vendors). Please see the spp product home page for more information, including support matrices and iso image downloads. If you're unsure about using in-distro vs HPE drivers, please refer to this quick position statement on the subject.


NOTICE: The Service Pack for ProLiant is now divided into product generations. Please susbscribe to the appropriate "spp" repo based on your generation of HPE Server hardware, ie. spp-gen10, spp-gen9, spp-gen8, spp-g7. (what's my gen?)


  Browse
(gen10, gen9)

Browse
(gen8)

Browse
(G7)


Subscribe your system to the spp repository


Red Hat Enterprise Linux

Cut-n-paste the following section (substituting generation, distribution, architecture and project version) into /etc/yum.repos.d/spp.repo on your RedHat system:


[spp]
name=Service Pack for ProLiant
baseurl=http://downloads.linux.hpe.com/repo/spp-gen/rhel/dist_ver/arch/project_ver
enabled=1
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/GPG-KEY-ServicePackforProLiant


Where:

   gen           gen10, gen9, gen8, g7, g6  (what's my gen?)
   dist_ver      7.3, 7.2, 7.1, 7.0, 6.8, 6.7, 6.6, 6.5, 6.4, 6.3
   arch          i386, x86_64  
   project_ver   current, 2017.07.0, 2017.04.0, 2016.10.0, 2016.04.0, 2015.10.0,  2015.06.0, 2015.04.0
        


SUSE Linux Enterprise Server

Cut-n-paste the following section (substituting generation, distribution, architecture and project version) into /etc/zypp/repos.d/spp.repo on your SUSE system:


[spp]
name=Service Pack for ProLiant
baseurl=http://downloads.linux.hpe.com/repo/spp-gen/suse/dist_ver/arch/project_ver
enabled=1
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/GPG-KEY-ServicePackforProLiant


Where:

   gen           gen10, gen9, gen8, g7, g6  (what's my gen?)
   dist_ver      SLES12-SP2, SLES12-SP1, SLES12, SLES11-SP3, SLES11-SP2, SLES11-SP1
   arch          i386, x86_64  
   project_ver   current, 2017.07.0, 2017.04.0, 2016.10.0, 2016.04.0, 2015.10.0, 2015.06.0, 2015.04.0
        


Installing spp packages

List the packages in the repository

# yum --disablerepo="*" --enablerepo="spp" list available


Install a specific package

# yum install packagename


Contact